Updating to Maven 2.0.9

There are a couple of cool improvements in there (most notably the fixed version of most plugins in the superpom – the end of our release plugin nightmares?), and now’s probably the best time to do this. (would admittedly have been even better prior to 3.6 M1, but hey) I’ll update the configuration of the maven-enforcer-plugin, so if you haven’t done so yet, and want to build Magnolia’s latest trunk, you’ll have to update your Maven installation too.